Announcement

Collapse
No announcement yet.

How to share Wifi/Airport Internet Connection through Ethernet on Mac & Windows

Collapse
X
  • Filter
  • Time
  • Show
Clear All
new posts

  • How to share Wifi/Airport Internet Connection through Ethernet on Mac & Windows


    On Mac:

    1) Apple Menu > System Preferences
    2) Click on Network, in the Show menu select Built-in Ethernet.
    3) Click on TCP/IP and in the Configure IPv4 menu, select Using DHCP with manual address
    4) Use these settings

    IP Address: 192.168.2.1
    Subnet Mask: 255.255.255.0 (should already be set this)

    5) Click Apply Now.
    6) In the Show menu, select Network Port Configurations.
    7) Click and drag Airport above everything listed here if it isn't already.



    Return to the main System Preferences page with the Show All button.
    8) Click on Sharing and select the Internet tab.
    9) Choose Airport from the Share your connection from menu and tick the Built-in Ethernet option below in the To computers using box.
    10) Click the Start button to begin sharing.

    On PC:


    1) Go to Control Panel and double click Network Connections.
    2) Right click Local Area Connection and select Properties. Note, you may have more than one local area connection like I do. Select the one which you've connected the ethernet cable to (obviously).
    3) In the General tab select Internet Protocol (TCP/IP) and click the Properties button.
    4) Select Obtain an IP address automatically and also make sure Obtain DNS server address automatically is also selected.
    5) Click OK on this window and OK on the one below. Test your internet connection. If it doesn't work, go back to Step 4 in this PC section and try this:

    Select Use the following IP address and these settings:

    IP address: 192.168.2.2
    Subnet Mask: 255.255.255.0
    Default Gateway: 192.168.2.1

    Leave the DNS server fields blank and click OK.

    This should get it to work, excuse the long post, but thought I'd break it down clearly

    If it still doesn't work then you might want to turn off XP's firewall and also set the Workgroup to be the same for PC & Mac. Also I'm not sure if this is a necessity, but use a cross over ethernet cable. I know mac's are smart and don't care what type of cables you use, but PC's aren't.

    Credits to melon @ macworld.com
Working...
X